Cleanup html docs using dpatch
[manu/mod-proxy-html.git] / debian / rules
index 6d0655a..743e180 100755 (executable)
@@ -9,9 +9,12 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
+patch:
+       dpatch apply-all
+
 build: build-stamp
 
-build-stamp:
+build-stamp: patch
        dh_testdir
        apxs2 -c -I/usr/include/libxml2 mod_proxy_html.c
        touch build-stamp
@@ -22,6 +25,8 @@ clean:
        rm -f build-stamp mod_proxy_html.la  mod_proxy_html.lo  mod_proxy_html.o  mod_proxy_html.slo
        rm -rf .libs
        dh_clean 
+       dpatch deapply-all
+       rm -rf debian/patched
 
 install: build
        dh_testdir
@@ -30,6 +35,8 @@ install: build
        dh_installdirs
        dh_install
 
+binary-indep:
+
 binary-arch: build install
        dh_testdir
        dh_testroot
@@ -47,4 +54,4 @@ binary-arch: build install
        dh_builddeb
 
 binary: binary-arch
-.PHONY: build clean binary-arch binary install
+.PHONY: build clean binary-arch binary-indep binary install patch