Remove non-existent make target
[manu/suphp.git] / debian / rules
index 9a88938..13f726b 100755 (executable)
@@ -5,9 +5,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -45,7 +42,7 @@ build:
 clean:
        dh_testdir
        dh_testroot
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
        rm -f config.log config.status src/config.h
        rm -f libtool src/stamp-h
        find . -name .libs | xargs rm -rf
@@ -59,8 +56,9 @@ clean:
 install: build-apache2
        dh_testdir
        dh_testroot
-       dh_clean -k
+       dh_prep
        find -name ".svn" -type d | xargs rm -rf
+       find -name ".git" -type d | xargs rm -rf
        dh_installdirs
        dh_install
        docbook-to-man debian/suphp-common.manpage.sgml > debian/suphp-common/usr/share/man/man8/suphp.8
@@ -105,4 +103,4 @@ binary-arch: install
        dh_builddeb
 
 binary: binary-indep binary-arch
-.PHONY: configure build build-apache2 clean binary-indep binary-arch binary install patch unpatch
+.PHONY: configure build build-apache2 clean binary-indep binary-arch binary install patch