Use dh_apache2
[manu/suphp.git] / debian / rules
index 273ed03..2dc1388 100755 (executable)
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with quilt,autotools-dev,autoreconf
+       dh $@  --with quilt,autotools-dev,autoreconf,apache2
 
 override_dh_auto_configure:
-       CPPFLAGS="`pkg-config --cflags apr-1`" ./configure --prefix=/usr \
+       CFLAGS="$(CFLAGS) `pkg-config --cflags apr-1`" ./configure --prefix=/usr \
        --sysconfdir=/etc/suphp \
        --with-apxs=/usr/bin/apxs2 \
        --with-apache-user=www-data \
-       --with-php=/usr/bin/php-cgi \
        --sbindir=/usr/lib/suphp \
        --with-setid-mode=owner \
        --with-logfile=/var/log/suphp/suphp.log
@@ -42,3 +41,5 @@ override_dh_fixperms:
        dh_fixperms
        chmod u+s debian/suphp-common/usr/lib/suphp/suphp
 
+override_dh_makeshlibs:
+       # Not needed here, not a dynamic lib