Use CFLAGS instead of CPPFLAGS and append to existing values
[manu/suphp.git] / debian / rules
index 273ed03..96b58c3 100755 (executable)
@@ -13,7 +13,7 @@
        dh $@  --with quilt,autotools-dev,autoreconf
 
 override_dh_auto_configure:
-       CPPFLAGS="`pkg-config --cflags apr-1`" ./configure --prefix=/usr \
+       CFLAGS="$(CFLAGS) `pkg-config --cflags apr-1`" ./configure --prefix=/usr \
        --sysconfdir=/etc/suphp \
        --with-apxs=/usr/bin/apxs2 \
        --with-apache-user=www-data \
@@ -42,3 +42,5 @@ override_dh_fixperms:
        dh_fixperms
        chmod u+s debian/suphp-common/usr/lib/suphp/suphp
 
+override_dh_makeshlibs:
+       # Not needed here, not a dynamic lib