Use CFLAGS instead of CPPFLAGS and append to existing values
[manu/suphp.git] / debian / rules
index da221d7..96b58c3 100755 (executable)
 #export DH_VERBOSE=1
 
 %:
-       dh $@  --with quilt
+       dh $@  --with quilt,autotools-dev,autoreconf
 
 override_dh_auto_configure:
-       CPPFLAGS="`pkg-config --cflags apr-1`" ./configure --prefix=/usr \
+       CFLAGS="$(CFLAGS) `pkg-config --cflags apr-1`" ./configure --prefix=/usr \
        --sysconfdir=/etc/suphp \
        --with-apxs=/usr/bin/apxs2 \
        --with-apache-user=www-data \
@@ -23,7 +23,7 @@ override_dh_auto_configure:
        --with-logfile=/var/log/suphp/suphp.log
 
 
-override_dh_install: build-apache2
+override_dh_install:
        dh_install
        docbook-to-man debian/suphp-common.manpage.sgml > debian/suphp-common/usr/share/man/man8/suphp.8
        install -m 644 debian/suphp-common.lintian-override debian/suphp-common/usr/share/lintian/overrides/suphp-common
@@ -42,3 +42,5 @@ override_dh_fixperms:
        dh_fixperms
        chmod u+s debian/suphp-common/usr/lib/suphp/suphp
 
+override_dh_makeshlibs:
+       # Not needed here, not a dynamic lib