Lintian cleanup
[manu/suphp.git] / debian / rules
index 9a88938..f6c90db 100755 (executable)
@@ -5,9 +5,6 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1
 
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=4
-
 # These are used for cross-compiling and for saving the configure script
 # from having to guess our platform (since we know it already)
 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
@@ -45,7 +42,7 @@ build:
 clean:
        dh_testdir
        dh_testroot
-       -$(MAKE) clean
+       [ ! -f Makefile ] || $(MAKE) clean
        rm -f config.log config.status src/config.h
        rm -f libtool src/stamp-h
        find . -name .libs | xargs rm -rf