Use quilt instead of dpatch
[manu/libnss-mysql-bg.git] / debian / rules
index 4e0717a..3ea33fb 100755 (executable)
@@ -30,12 +30,11 @@ major=2
 # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
 
 patch:
-       dpatch apply-all
+       dh_quilt_patch
 
 configure: configure-stamp
 configure-stamp: patch
        dh_testdir
-       chmod 0755 aux/mkinstalldirs
        ./configure
        touch configure-stamp
 
@@ -53,13 +52,13 @@ clean:
        [ ! -f Makefile ] || $(MAKE) distclean
        rm -f config.log
        dh_clean
-       dpatch deapply-all
+       dh_quilt_unpatch
        rm -rf debian/patched
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
        dh_installdirs
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        dh_movefiles