Remove useless directive
[manu/libnss-mysql-bg.git] / debian / rules
index c0d750f..66dc421 100755 (executable)
@@ -35,7 +35,6 @@ patch:
 configure: configure-stamp
 configure-stamp: patch
        dh_testdir
-       chmod 0755 aux/mkinstalldirs
        ./configure
        touch configure-stamp
 
@@ -50,7 +49,7 @@ clean:
        dh_testdir
        dh_testroot
        rm -f build-stamp configure-stamp
-       -$(MAKE) distclean
+       [ ! -f Makefile ] || $(MAKE) distclean
        rm -f config.log
        dh_clean
        dpatch deapply-all
@@ -59,7 +58,7 @@ clean:
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
        dh_installdirs
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        dh_movefiles