Add per policy required build-arch/build-indep
[manu/libnss-mysql-bg.git] / debian / rules
index 4e0717a..7682098 100755 (executable)
@@ -30,17 +30,18 @@ major=2
 # awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
 
 patch:
-       dpatch apply-all
+       dh_quilt_patch
 
 configure: configure-stamp
 configure-stamp: patch
        dh_testdir
-       chmod 0755 aux/mkinstalldirs
        ./configure
        touch configure-stamp
 
 
-build: build-stamp
+build: build-arch build-indep
+build-arch: build-stamp
+build-indep: build-stamp
 build-stamp: configure-stamp
        dh_testdir
        $(MAKE)
@@ -53,13 +54,13 @@ clean:
        [ ! -f Makefile ] || $(MAKE) distclean
        rm -f config.log
        dh_clean
-       dpatch deapply-all
+       dh_quilt_unpatch
        rm -rf debian/patched
 
 install: build
        dh_testdir
        dh_testroot
-       dh_clean -k 
+       dh_prep
        dh_installdirs
        $(MAKE) install DESTDIR=$(CURDIR)/debian/tmp
        dh_movefiles